VScode error when logging in

Hi all,

It seems like when using VSCode to log in on discovery, it keeps prompting me to enter my password, or it says pid is running, I tried to delete VScode on the cluster, etc. but does not work.

I remember this is related to the load on Discovery, can someone help me fix it?
Thank you!

@mingchac The VS Code Remote - SSH extension is not reliable enough for use on our HPC systems, so we don’t recommend using it. We would need to reboot the login nodes often in order to support it, which disrupts other users.

Could you try using the sshfs extension instead? https://github.com/SchoofsKelvin/vscode-sshfs

Several things you may try:

  1. use discovery2.usc.edu as your ssh host address, as pointed out in this previous post.
  2. delete the previous vscode server on the cluster.
  3. add the following in your settings.json for vscode:
    "remote.SSH.showLoginTerminal": true,
    "remote.SSH.useLocalServer": true,
    "remote.SSH.localServerDownload": "auto",

These steps worked for me on Windows.