Conda install tpmcalculator

I’m trying to install the bioconductor package tpmcalculator (Package Recipe 'tpmcalculator' — Bioconda documentation), and it continues to fail. Here is my code and the output I get:
module load anaconda3
[bweekley@discovery2 bweekley]$ conda install tpmcalculator
Collecting package metadata (current_repodata.json): done
Solving environment: done

Package Plan

environment location: /spack/apps/anaconda3/2021.05

added / updated specs:
- tpmcalculator

The following NEW packages will be INSTALLED:

bamtools bioconda/linux-64::bamtools-2.5.1-he513fc3_6
tpmcalculator bioconda/linux-64::tpmcalculator-0.0.4-h7376a40_0

The following packages will be UPDATED:

conda 4.10.3-py38h578d9bd_0 → 4.11.0-py38h578d9bd_0

Proceed ([y]/n)? y

Preparing transaction: done
Verifying transaction: failed

EnvironmentNotWritableError: The current user does not have write permissions to the target environment.
environment location: /spack/apps/anaconda3/2021.05
uid: 322036
gid: 30218

So it seems the issue is the install is requiring me to UPDATE conda, which of course I don’t have permission to do. But when I try to ignore updates (–freeze-install, conda install — conda 4.11.0.post20+db4e1c0f2 documentation), it gives the exact same error. How should I proceed?
Thank you!

@bweekley The issue is that it’s trying to install into the base environment, which users don’t have permission to do. First create a custom environment and then try installing the package:

mamba create --name <env_name>
conda activate <env_name>
mamba install -c bioconda tpmcalculator

Mamba is a drop-in replacement for most Conda commands that offers faster solving and installing.

Thank you! That worked great.